Online Tutorials & Training Materials | STechies.com
Register Login

Query script generation failed. See your BusinessObjects administrator. {0} (WIS 00013) Could not resolve prompt answer :Prompt value (WIS 00000)

|| || 1

Query script generation failed. See your BusinessObjects administrator. {0} (WIS 00013) Could not resolve prompt answer :Prompt value (WIS 00000)
Stechies

Having following Issue:

  • In the DEV environment. create a Webi report that is based on a BICS connection to an SAP BW BEx query.
  • Define a Webi query filter in the Webi report and select the filter to be "In List" and specify some values (all of these values should exist in the BW system that is being connected to).
  • Run the report in the DEV envioronment and notice that it runs without any issue.
  • Promote the Webi report and all of the associated dependencies to the QA environment.
  • Ensure that one of the selected value for the object in the query filter that was specified in Step 2 does not exist in the QA environment.
  • Run the Webi report without removing any of the values that have been selected for the query filter (including the value that doesn't exist in the QA environment).
  • When the report is run, the error "Query script generation failed. See your BusinessObjects administrator. {0} (WIS 00013) Could not resolve prompt answer :<Prompt value> (WIS 00000)" is shown.

Related: WIS 10901 a Database Error Occurred While Creating Web Intelligence Report

Solution:

The product is working as expected. Since one of the selected values that has been specified in the query filter exists in the DEV environment, it runs without any issue.  When the report is run with the value that doesn't exist in the BW database, an error is shown that mentions that the query could not be executed.

Before the Webi report is run, any values that don't exist in the BW database should be removed as selected values.  The Webi report will then run successfully.


Comments

  • 26 Jan 2017 3:06 am

    Thank you for this post.  We had same issue in development after applying 4.2 that it was error related to update, but in dev we did not have data in BW for the list values in the webi filter for the query

Related Articles

0.0169 seconds.