Online Tutorials & Training Materials | STechies.com
Register Login

Consume external web service error

|| || 0

Consume external web service error
Stechies

In order to consume external web service from SAP, I have created a proxy object for given WSDL URL and a logical port where I put given endpoint URL. Also, I have created a function module from which external service should be called. When I test proxy object from SE80, I get the following error:

 <?xml version="1.0" encoding="utf-8" ?>
- <asx:abap xmlns:asx="http://www.sap.com/abapxml" version="1.0">
- <asx:values>
  <SYSTEMFAULT href="#o163" />
  </asx:values>
- <asx:heap xmlns:xsd="http://www.w3.org/2001/XMLSchema"      xmlns:abap="http://www.sap.com/abapxml/types/built-in" xmlns:cls="http://www.sap.com/abapxml/classes/global" xmlns:dic="http://www.sap.com/abapxml/types/dictionary">
- <cls:CX_AI_SYSTEM_FAULT id="o163">
- <CX_ROOT>
  <TEXTID>F63AFF63DBE4BB4786A7F52CC4167145</TEXTID>
  <PREVIOUS />
  <KERNEL_ERRID />
- <INTERNAL_SOURCE_POS>
  <PROGID>181</PROGID>
  <CONTID>1110</CONTID>
  </INTERNAL_SOURCE_POS>
  </CX_ROOT>
  <CX_STATIC_CHECK />
- <CX_AI_SYSTEM_FAULT>
  <CODECONTEXT>http://www.sap.com/xml_errorcodes</CODECONTEXT>
  <CODE>SoapFaultCode:4</CODE>
  <ERRORTEXT>net.tmobile.ei.messaging.datatypes.SOABPException</ERRORTEXT>
  <LANGUAGE />
  </CX_AI_SYSTEM_FAULT>
  </cls:CX_AI_SYSTEM_FAULT>
  </asx:heap>
  </asx:abap>

When I run function module which calls web service, an error cx_ai_system_fault is caught. Actual error is: INTERNAL_SOURCE_POS Structure: flat & not charlike CODE SoapFaultCode:4 ERRORTEXT net.tmobile.ei.messaging.datatypes.SOABPException Even when I comment complete code from function module except part where I call web service, the error is the same. I couldn't find any conclusion after googling about this subject. Any help would be appreciated. Thank you in advance.