Online Tutorials & Training Materials | STechies.com
Register Login
Advertisement

Current versions of BR*Tools and SAPDBA

|| 0

Current versions of BR*Tools and SAPDBA
Stechies

Current and corrected versions of BR*Tools (BRBACKUP, BRARCHIVE, BRCONNECT, BRRECOVER, BRRESTORE, BRSPACE, BRTOOLS) and SAPDBA.


-----------------------------------------------------------------------
Contents
-----------------------------------------------------------------------

[1] Which programs are contained in the BR*Tools/SAPDBA program package?
[2] How can I access BR*Tools and SAPDBA?
[3] How can I copy the BR*Tools/SAPDBA program package?
[4] How do I unpack the BR*Tools/SAPDBA program package?
[5] After copying and unpacking (for UNIX only):
[6] Where can I find information about BR*Tools and SAPDBA?
[7] Remarks

The BR*Tools/SAPDBA correction procedure corresponds to the general SAP standard procedure.

-----------------------------------------------------------------------
[1] Which programs are contained in the BR*Tools/SAPDBA program package?
-----------------------------------------------------------------------

The BR*Tools/SAPDBA program package contains the following programs:

BRARCHIVE
BRBACKUP
BRCONNECT
BRRECOVER (as of 6.20, patch level 100)
BRRESTORE
BRSPACE (as of 6.40)
BRTOOLS

SAPDBA (up to Release 6.20,
SAPDBA 6.20 can also be used for SAP Release 6.40)

-----------------------------------------------------------------------
[2] How can I access BR*Tools and SAPDBA?
-----------------------------------------------------------------------

The BR*Tools/SAPDBA are available on SAP Service Marketplace(http://service.sap.com). The versions BR*Tools/SAPDBA 6.20 are also suitable for older SAP systems and are recommended, provided they run with an Oracle Release 9.0 and higher.
The BR*Tools 6.40 for Oracle 9.2 have been available and released for productive use since May 2004.
As of November 2005, the BR*Tools 7.00 for Oracle 10g are also available and are released for productive use.

Caution:
--------
Version BR*Tools/SAPDBA 4.6D has not been enhanced since 2003. BR*Tools/SAPDBA 6.20 contains corrections.


There are no BR*Tools and SAPDBA versions specific to UNICODE systems. The programs can also be used for UNICODE.

--------------------------------------------------------
Main path for downloading from SAP Marketplace
--------------------------------------------------------

http://service.sap.com/patches
--> SAP Software Distribution Center
--> Download
--> SAP Support Packages and Patches
--> Entry by Application Group

-----------------------------------------------------------------------
[2.1] Version 7.00:
-----------------------------------------------------------------------

The BR*Tools 7.00 are available on the SAP Service Marketplace as aSAPCAR Archive.
The BR*Tools 7.00 package can be used for all SAP releases that run with an Oracle 10g database, or an Oracle 9.2 database after installing the Oracle Instant Client 10g on the Oracle 9.2 database server. For more information, see Note 849483.
The 7.00 BR*Tools can be used for non-ABAP stack SAP systems with out restrictions (for example, J2EE-only systems, portals, MDM, requisite and so on). On non-ABAP stack systems, some tax tables may not exist. Therefore, also refer to Notes 320457 and 892294.
The BR*Tools documentation is described under [6] below. The documentation contains recommendations on the type and regularity of repeated database administration activities such as back-ups, statistics calculations and so on.

Depending on your system configuration, the following table describes the correct path to the BR*Tools program package:

Operating system Oracle Version SAP Kernel Access Path
--------------------------------------------------------------------
LINUX 32-bit 10g 32-bit 32-bit 1
WINDOWS 32-bit 10g 32-bit 32-bit 1
WINDOWS 64-bit 10g 64-bit 64-bit 2
UNIX 64-bit 10g 64-bit 64-bit 2
--------------------------------------------------------------------

Access Path 1:
Main path as starting point (see point [2]):
--> SAP NetWeaver
--> SAP NETWEAVER
--> SAP NETWEAVER 2004S
--> Entry by Component
--> Application Server ABAP
--> SAP KERNEL 7.00 32-BIT
--> Linux/IA32 | Windows/IA32
-->Oracle
--> DBATL700O10_nn

Access Path 2:
Main path as starting point (see point [2]):
--> SAP NetWeaver
--> SAP NETWEAVER
--> SAP NETWEAVER 2004S
--> Entry by Component
--> Application Server ABAP
--> SAP KERNEL 7.00 64-BIT
--> AIX/64bit | HPUX/64bit | SOLARIS/64bit | ...
--> ORACLE
--> DBATL7000O10_nn

Caution:
========
The program package for BR*Tools 7.00 for TRU64 is not contained in the paths defined above, but in the paths defined for Version 6.40.

-----------------------------------------------------------------------
[2.2] Version 6.40
-----------------------------------------------------------------------

The BR*Tools 6.40 are available on the SAP Service Marketplace as aSAPCAR Archive.
The 6.40 BR*Tools can be used for all SAP releases that run with an Oracle-9.2 database. For more information, see Note 680046.
Version 6.40 BR*Tools can also be used for non-ABAP Stack SAP systems such as pure J2EE systems, portals, MDM, Requisite, and so on, with a minor loss of functionality. Since some control tables are not necessary on non-ABAP stack systems, refer also to Note 320457.
The BR*Tools documentation is described under [6] below. The documentation contains recommendations on the type and regularity of repeated database administration activities such as back-ups, statistics calculations and so on.

Depending on your system configuration, the following table describes the correct path to the BR*Tools program package:

Operating system Oracle Version SAP Kernel Access Path
--------------------------------------------------------------------
LINUX 32-bit 9.2 32-bit 32-bit 1
WINDOWS 32-bit 9.2 32-bit 32-bit 1
WINDOWS 64-bit 9.2 64-bit 64-bit 2
UNIX 64-bit 9.2 64-bit 64-bit 2
--------------------------------------------------------------------

Access Path 1:
Main path as starting point (see point [2]):
--> SAP NetWeaver
--> SAP NETWEAVER
--> SAP NETWEAVER 04
--> Entry by Component
--> Application Server ABAP
--> SAP KERNEL 6.40 32-BIT
--> Linux/IA32 | Windows/IA32
-->Oracle
--> DBATL640O92_nn

Access Path 2:
Main path as starting point (see point [2]):
--> SAP NetWeaver
--> SAP NETWEAVER
--> SAP NETWEAVER 04
--> Entry by Component
--> Application Server ABAP
--> SAP KERNEL 6.40 64-BIT
--> AIX_64 | HPUX_64 | SOLARIS_64 | ...
--> ORACLE
--> DBATL640O92_nn

-----------------------------------------------------------------------
[2.3] Version 6.20
-----------------------------------------------------------------------

The BR*Tools /SAPDBA 6.20 are available as SAPCAR archive on SAP ServiceMarketplace and on SAP servers sapservX.

The 6.20 tools can be used for all SAP systems that run with an 8.1 or a 9.2 database.
sapdba 6.20 (for example reorganization and TSP administration) can also be used with SAP 6.40. However, the SAPDBA parts for Restore/Recovery are not compatible with the 6.40 BR*Tools.

Depending on your system configuration, the following table describes the correct path to your BR*Tools/SAPDBA program package:

Operating system Oracle Version SAP Kernel Access Path
--------------------------------------------------------------------
LINUX 32-bit 8.1, 9.2 32-bit 32-bit 1
NT/I386 32-bit 8.1, 9.2 32-bit 32-bit 1
UNIX 64-bit 8.1, 9.2 64-bit 64-bit 2
--------------------------------------------------------------------

Access Path 1:
Main path as starting point (see point [2]):
--> SAP Application Components
--> SAP R/3
--> SAP R/3 4.6C
--> Entry by Component
--> SAP KERNEL 4.6D_EXT 32-Bit
--> (32bit:) LINUX | Windows
-->Oracle
--> DBATL620O92_XXX.CAR

Access Path 2:
Main path as starting point (see point [2]):
--> SAP Application Components
--> SAP R/3
--> SAP R/3 4.6C
--> Entry by Component
--> SAP KERNEL 4.6D_EXT 64-Bit
--> (64bit:) AIX | HP-UX | Linux | SOLARIS | TRU64
--> ORACLE
--> DBATL620O92_XXX.CAR (not for AIX4_64)

BR*Tools/SAPDBA 6.20 are available for Oracle 8.1 and 9.2 and (apart from LINUX and NT) for 64-bit systems only.
The platform RELIANT is no longer supported in Version 6.20.

-----------------------------------------------------------------------
[3] Copying the BR*Tools/SAPDBA program package
-----------------------------------------------------------------------

You can copy the programs from SAP Service Marketplace using thedownload function of the Marketplace. For more information, see Note 19466.

-----------------------------------------------------------------------
[4] Unpacking the BR*Tools/SAPDBA program package
-----------------------------------------------------------------------

For *.CAR archives use CAR, for example:

CAR -xvf DBATL610O80.CAR
CAR -xvf SAPDBA.CAR,

for *.SAR archives use SAPCAR, for example:

SAPCAR -xvf DBATL620O81.SAR

-----------------------------------------------------------------------
[5] After copying and unpacking (for UNIX only):
-----------------------------------------------------------------------

Check the owner, group, and permissions for BR*Tools and SAPDBA asdescribed in Note 113747.

(Up to 4.6D, the same settings were valid for SAPDBA as for brarchive and brbackup, but this has changed to brconnect after the command line options were transferred.)

File libsbt.* is a dynamic backup library (DLL). By default, it is not used. For more information about this library, see Note 142635. The settings for this are:
-rwxr-xr-x <sid>adm sapsys ... libsbt.*

Note 1: (for UNIX and LINUX only)
----------

Given that BR*Tools and SAPDBA for Oracle 8.1 as of Version 6.10 (packages DBATL610O81.SAR and higher) are dynamically linked to the Oracle client library, an additional symbolic link must be created on UNIX platforms on the database server in SAP Releases 4.X and 3.X to make them executable for user <sid>adm:

mkdir /oracle/client
mkdir /oracle/client/92x_64 (for Oracle 64-bit)
mkdir /oracle/client/92x_32 (for Oracle 32-bit)

Note that you must NOT replace the 'x' in the '92x_64' directory with a number. You must create an 92x_64 (or 92x_32) directory.

If the $ORACLE_HOME/lib64 directory is available (platform-specific),then:

ln -s $ORACLE_HOME/lib64 /oracle/client/92x_64/lib

otherwise:

ln -s $ORACLE_HOME/lib /oracle/client/92x_64/lib (for Oracle 64-bit)
ln -s $ORACLE_HOME/lib /oracle/client/92x_32/lib (for Oracle 32-bit)

If several installations of Oracle software exist on the database host, the link should point to the installation with the *lowest* patch level.

Note 2:
----------

For R/3 systems 4.6X, the final release 4.6D applies, that is, each of those releases should be operated with the 4.6D kernel. For this reason, the kernel release under Binary Patches is the same as or higher than the R/3 Release.

-----------------------------------------------------------------------
[6] Where can I find information about BR*Tools?-----------------------------------------------------------------------
You can find current information and documentation about BR*Tools in theSAP Developer Network (SDN) at www.sdn.sap.com/irj/sdn/ora.
(refer to "SAP on Oracle Knowledge Center" in the bottom part of the page)

There (or directly on http://help.sap.com ) you can find the online documentation for the BR*Tools program package as of Release 6.40.


-----------------------------------------------------------------------
[7] Remarks
-----------------------------------------------------------------------

1.
To import the new versions of BR*Tools and SAPDBA, an R/3 upgrade is not necessary. The programs are generally independent of the rest of the R/3 environment and can be downloaded from SAPNet without upgrade.

2.
BR*Tools and SAPDBA are downward-compatible regarding two SAP main releases: the current and previous main releases.

BR*Tools/SAPDBA 6.20 are presently downward-compatible with three main SAP releases. They can still be used with all SAP 3.X maintenance levels. A prerequisite for that is also an Oracle version 8.0 or higher.

Use the same release of the programs BR*Tools and SAPDBA.

3.
The 6.XX executables are linked to operating system versions which are intended for SAP 6.XX. As a result, they may not run on lower operating system versions (which are allowed for SAP 4.XX). See also Note 407314 or www.service.sap.com/pam.


Advertisement
Advertisement
Advertisement