Online Tutorials & Training Materials | STechies.com
Register Login

SAPDHI: SAPDP00 not reached and WSAEWOULDBLOCK

|| || 3

SAPDHI: SAPDP00 not reached and WSAEWOULDBLOCK
Stechies

SAPDHI:sapdp00 not reached and WSAEWOULDBLOCK : Resource Temporarily unavailable

I have installed a SAP ERP 6.0 on SUSE with Maxdb. The installation was concluded with successful. I have started SAP instance with the command startsap all and I could see that the Instance is look like working. 

From a workstation, I am getting to ping the server but when I try to use SAP GUI, I am getting an error saying : 

"SAPDHI:sapdp00" not reached 

Component : NI (Network Interface) 

Module : nibuf.cpp 

Line 4658 

Method NiBuf!ConnetÇ connection pending after 10000ms 

Return code : -10 

Error No : 10035 

Error Text : WSAEWOULDBLOCK : Resource Temporarily unavailable 

To check if the system is working I have executed the following command ps -ef | grep dw.sap  and the result was : 

SAPDHI:/ # ps -ef | grep dw.sap 
dhiadm 27676 27631 0 21:56 ? 00:00:02 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28023 27676 0 21:56 ? 00:00:02 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28026 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28030 27676 0 21:56 ? 00:00:01 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28036 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28039 27676 0 21:56 ? 00:00:01 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28080 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28081 27676 0 21:56 ? 00:00:01 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28083 27676 0 21:56 ? 00:00:04 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28086 27676 0 21:56 ? 00:00:01 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28087 27676 0 21:56 ? 00:00:05 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28093 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28103 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28109 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28110 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28117 27676 0 21:56 ? 00:00:01 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
dhiadm 28120 27676 0 21:56 ? 00:00:00 dw.sapDHI_DVEBMGS00 pf=/usr/sap/DHI/SYS/profile/DHI_DVEBMGS00_SAPDHI 
root 29089 5024 0 22:26 pts/0 00:00:00 grep dw.sap 
SAPDHI:/ # 


Comments

  • 09 May 2014 5:53 am Best Answer

    Check the routing on the server. The last time I had that issue, the 
    default gateway was too many hops away from my remote site. I changed the 
    default gateway for those routes to the firewall and that resolved the 
    issue. 

     

  • Sonia Barwar
    09 May 2014 5:51 am Helpful Answer

    Open a command prompt on the workstation and enter the following: 
    telnet SAPDHI 3200 
    telnet SAPDHI 3300 
    telnet SAPDHI 3600 

    See if the telnet is successful. It is possible firewall ports are not open

  • 25 Jul 2016 11:02 pm

    you can check this blog if fiewall setting is the issue.

    http://scn.sap.com/community/gui/blog/2016/07/20/minisap-trail-on-vm-access-issue-from-host-system-wsaewouldblock-resource-temporarly-unavailable