Online Tutorials & Training Materials | STechies.com
Register Login
Advertisement

SAP JVM installation prerequisites

|| 0

SAP JVM installation prerequisites
Stechies

The SAP JVM requires specific operating system versions, additional libraries and library patches.

Find below the list of minimum requirements for the operating system versions. Required additional libraries and library patches are listed as well.

Windows (all processor platforms)

  • Windows-based systems require the installation of the "Microsoft Visual C++ 2010 Redistributable Package", which can be obtained from the Microsoft website.


Windows (x86)

  •  Minimum OS versions

    Windows Server 2003 (SP 2)
    Windows XP (SP 2)

Windows (X64, x86_64)

  •  Minimum OS versions (for recommended service packs see note 30478)

       Windows Server 2003 (SP 2)
       Windows XP (SP 2)

Windows (IA64)

  • Minimum OS versions (for recommended service packs see note 30478)

    Windows Server 2003 (SP 2)

Linux (all processor platforms)

  • Minimum OS versions

    Red Hat Enterprise Linux 4 Update 5 (RHEL 4.5)
    (more installation information is available in the notes 722273 (RHEL 4), 1048303 (RHEL 5) and 1496410 (RHEL 6))

    Novell SuSE Linux Enterprise Server 9
    (more installation information is available in the notes 797084 (SLES 9), 958253 (SLES 10) and 1310037 (SLES 11))
     
  • Required additional libraries

    Novell SUSE Linux Enterprise Server 9 only:
    (rpm packages): libstdc++-4.1, libgcc-4.1 (see note 1021236 for details)

AIX

  •  Minimum OS version

    For SAP JVM 5.1 and 6.1: AIX 5.3
    For SAP JVM 4.1: AIX 5.3 TL 9
     
  • Required library patches
    AIX 5.x: xlC.aix50.rte and xlC.rte >= 8.0.0.5
    AIX 6.x: xlC.aix61.rte and xlC.rte >= 9.0.0.1
     
  • Required filesets when using graphical user interfaces, e.g. SAP installation or upgrade tools. The fileset names are those for AIX 6.1, names for other AIX versions may vary slightly.

    X11.adt.bitmaps
    X11.adt.imake
    X11.adt.include
    X11.adt.lib
    X11.base.common
    X11.base.lib
    X11.base.rte
    X11.base.smt
    X11.base.xpconfig
    X11.fnt.coreX
    X11.fnt.defaultFonts
    X11.fnt.iso1
    X11.fnt.iso_
    X11.motif.lib
    X11.motif.mwm
    X11.vsm.lib
    X11.Dt.rtebos.rte.X11
     
  • For the U.S. English locale following filesets are required
    X11.loc.en_US.base.lib
    X11.loc.en_US.base.rte
    X11.msg.en_US.adt.imake
    X11.msg.en_US.base.common
    X11.msg.en_US.base.rte
    X11.msg.en_US.motif.lib
    X11.msg.en_US.motif.mwm
    X11.msg.en_US.vsm.rte

IBM i

  • Minimum OS version
    IBM i 5.4 (former V5R4)

Solaris (SPARC64)

  • Minimum OS version
    Solaris 9
     
  • Required library patches
    Solaris 9:

        - C++ Shared library patch: 111711-12, 111712-12
        - Patches recommended in note 550585 and 1109536

        Solaris 10:
        - C++ Shared library patch: 119963-04
        - Patches recommended in note 832871 and 1109536

 

Solaris (X64)

  •  Minimum OS versio
    Solaris 10
     
  • Required library patch
    C++ Shared library patch: 119964-04
    Patches recommended in note 908334 and 1109536

HP-UX (all processor platforms)

  • Please make sure your HP-UX system has installed all patches described in section: "SAP systems running kernel release 720" SAP note 837670.
  • Please make sure you have the correct version of the SAP Startup Framework installed, see note 1136099 for details
  • For HP-UX kernel parameter recommendations see note 172747.

HP-UX (PA-RISC64)

  • Minimum OS version

    HP-UX 11.11

HP-UX (IA64)

  • Minimum OS version

    HP-UX 11.23
     
  • SAP JVM 5.1 patch level 57 or newer especially requires the following HP-UX patches (also mentioned in note 837670):

    PHSS_38138 or newer (HP-UX 11.23)
    PHSS_38139 or newer (HP-UX 11.31)
     
  • All SAP JVM versions on HP-UX 11.31 require in addition to above the following HP-UX patch:

    PHKL_40208 (HP-UX 11.31)

 


Advertisement
Advertisement
Advertisement