Online Tutorials & Training Materials | STechies.com
Register Login

SXPG_COMMAND_EXECUTE failed for BRBACKUP

Shalesh Singh Visen || 02 Jan 2010 10:19 am || 4

Scheduled Backup SXPG_COMMAND_EXECUTE failed

Dear All,

OS : AIX, DB :Oracle , SAP ECC6.0

I got an error and online backup has scheduled in DB13 ( Production Server) when its reach the backup time its showing error.

NOTE: Production Server Backup has Automated, If I Execute Immediately, backup is running as well backup is running, if I use BRtools.

My Query is Scheduled Backup is not working in my Case...

Status : Scheduled failed

JOB LOG:

30.11.2009 17:26:56 Job started
30.11.2009 17:26:56 Step 001 started (program RSDBAJOB, variant &0000000000672, user ID BASIS)
30.11.2009 17:26:56 No application server found on database host - rsh/gateway will be used
30.11.2009 17:26:56 Execute logical command BRBACKUP On host PRODORADB
30.11.2009 17:26:56 Parameters:-u / -jid ALLOG20091130172655 -c force -t online -m all -p initIRPoffsite.sap -a -c force -p initIRP
30.11.2009 17:26:56 offsite.sap -cds
30.11.2009 17:27:28 SXPG_STEP_XPG_START: is_local_host: rc = 403
30.11.2009 17:27:28 SXPG_STEP_XPG_START: host = PRODORADB
30.11.2009 17:27:28 SXPG_STEP_XPG_START: is_local_r3_host: rc = 802
30.11.2009 17:27:28 SXPG_STEP_XPG_START: RFC_TCPIP_CONNECTION_OPEN: rc = 1003
30.11.2009 17:27:28 SXPG_STEP_COMMAND_START: SXPG_STEP_XPG_START returned: 1.003
30.11.2009 17:27:28 SXPG_COMMAND_EXECUTE(LONG)
30.11.2009 17:27:28 = 20091130172728
30.11.2009 17:27:28 COMMANDNAME = BRBACKUP
30.11.2009 17:27:28 ADDITIONAL_PARAMETERS =
30.11.2009 17:27:28 -u / -jid ALLOG20091130172655 -c force -t online -
30.11.2009 17:27:28 m all -p initIRPoffsite.sap -a -c force -p initIRP
30.11.2009 17:27:28 offsite.sap -cds
30.11.2009 17:27:28 LONG_PARAMS
30.11.2009 17:27:28 OPERATINGSYSTEM = ANYOS
30.11.2009 17:27:28 TARGETSYSTEM = PRODORADB
30.11.2009 17:27:28 DESTINATION
30.11.2009 17:27:28 SY-SUBRC = 1003
30.11.2009 17:27:28 SXPG_COMMAND_EXECUTE failed for BRBACKUP - Reason: program_start_error: For More Information, See SYS
30.11.2009 17:27:28 Job cancelled after system exception ERROR_MESSAGE

Please give suggestion to solve this issue


Comments

  • 02 Jan 2010 10:21 am Helpful Answer
    Most probably this is due to failure in RFC connection from where you have different DB and App server. If you run backup from db13, it executes the command on DB instance through an RFC connection SAPXPG_DBDEST_. 
     
    Please check if the RFC is working properly.
     
    For this connection to work properly you need two entries in the service file of the app server. sapgw30 3330 and sapdb30 3230. This is a automatically generated RFC. 
     
    Important Note: 446172- (SXPG_COMMAND_EXECUTE (program_start_error) in DB13
  • 02 Jan 2010 10:21 am Helpful Answer

    Maintain .rhosts entry in sidadm user on both the hosts PRODORADB / PRODORACI (HACMP)

  • 02 Jan 2010 10:23 am Helpful Answer

    We have 1 CI & 2 App. Instance

    Application Instance 1

    I have Checked RFC Destination SAPXPG_DBDEST_PRODORADB through SM59. when i give connection Test , its pinging . below result

    • Logon 185 msec
    • Transfer of 0 KB 198 msec
    • Transfer of 10 KB 200 msec
    • Transfer of 20 KB 200 msec
    • Transfer of 30 KB 201 msec

    Application Instance 2

    I have Checked RFC Destination SAPXPG_DBDEST_PRODORADB through SM59.

    When i give connection Test , its not pinging

    • Logon Connection Error
    • Error Details Error when opening an RFC connection
    • Error Details ERROR: timeout during allocate
    • Error Details LOCATION: SAP-Gateway on host PRDAPP2 / sapgw00
    • Error Details DETAIL: no connect of TP sapxpg from host PRODORADB after 20 sec
    • Error Details COMPONENT: SAP-Gateway
    • Error Details COUNTER: 3012
    • Error Details MODULE: gwr3cpic.c
    • Error Details LINE: 1973
    • Error Details RETURN CODE: 242
    • Error Details SUBRC: 0
    • Error Details RELEASE: 700
    • Error Details TIME: Tue Dec 29 20:30:06 2009
    • Error Details VERSION: 2

    Central Instaence (CI):

    I have Checked RFC Destination SAPXPG_DBDEST_PRODORADB through SM59. when i give connection Test , its pinging . below result

    • Logon 185 msec
    • Transfer of 0 KB 198 msec
    • Transfer of 10 KB 200 msec
    • Transfer of 20 KB 200 msec
    • Transfer of 30 KB 201 msec

    please advise me, the above error is related to Backup please suggest me to resolve the issue.

  • 07 Nov 2010 6:56 am Helpful Answer

    Kindly check your SIDADM pwd in DB hostname. if it is expired kindly reset your pwd & then try to check your SAPXPG_DBDEST_PRODORADB RFC.